Current Known Issues with Logic Pro X 10.5

LOGIC PRO X 10.5 ISSUE ALERT

On May 12th, 2020, Apple released Logic Pro X 10.5 for macOS. Unfortunately, this new version currently conflicts with many 3rd-party plugins including Polyverse plugins.

To avoid stability and performance issues affecting 3rd-party plugins, we highly recommend that you do not yet update to Logic Pro X 10.5 at this time.

The following Polyverse plugins are affected by this issue:

• Gatekeeper

Our development team is currently working on a fix, and we will release updates to our products as soon as possible.

Thank you for your patience and understanding while we work to resolve this issue.